Customer Support Guide

The following sections explain how to gather the data you need to send to PTC Technical Support to successfully resolve your issues.  Read the section or sections that refer to the software involved in your question.

Arbortext

CADDS, Optegra, and DIMENSION III

Creo Elements/Direct 

Creo Elements/Direct Drafting

Creo Elements/Direct Modeling

Creo Elements/Direct Model Manager and Creo Elements/Direct Drawing Manager

Creo Elements/Pro or Pro/ENGINEER

Creo Elements/Pro Mechancia

Creo Elements/Pro Routed Systems Designer

DIVISION ProductView

Electronic Design Entry (EDE)

FlexPLM

Info*Engine

Integrity

Intercomm

InterComm EDAcompare

InterComm EDAconduit

InterComm Expert

Mathcad

Windchill Import and Export

Windchill Information Modeler

Windchill Installation and Configuration

Windchill Visualization or Creo Elements/View

Arbortext

Application files of various types help Technical Support reproduce and resolve a problem with Arbortext products.

  • Arbortext Editor, Arbortext Styler, Arbortext Architect (Text Editor), and Arbortext PE Interactive (formerly E3 Interactive)—To save your application files, open the source document, and then select Tools > Save Application. Zip the files.
  • When using release 4.3.1 and later, enter the appsave command in the command window. When using release 4.3 and earlier, enter the bugsave command.
  • The files saved include the document instance, style sheet, document type, custom programming files, and environment information. For a nonstandard customization, ensure that all required files are in the appsave folder.
  • For details on using the appsave command, go to the Help-Topics menu, click the Search tab, and type appsave in the text box.
  • Arbortext Publishing Engine, Arbortext Contributor, Arbortext Dynamic Link Manager—Technical Support will work with you to obtain application files on the Arbortext Publishing Engine server.
  • Arbortext Advanced Print Publisher (formerly 3B2)—Prepare a scaled-down, *.3d file that exhibits the problem. Zip the file with all its referenced graphics.

CADDS, Optegra, and DIMENSION III

Collect the CADDS, Optegra, or DIMENSION III database files as directed by the technical support engineer handling your case.

Creo Elements/Direct

Application files of various types aid Technical Support in reproducing and resolving a problem. Typical file types follow:

Creo Elements/Direct Drafting

  • MI files
  • Trace file (echo, trace, undo)
  • IGES 2D / DXF / DWG data files

Creo Elements/Direct Modeling

  • Package (*.pkg) / Bundle (*.bdl) / 3D Data files (*.sd*)
  • Recorder Files (*.rec) via (load “recorder”)
  • Other 3D Data files, like *.anf, *.x_t (Parasolid), IGES, or STEP
  • Trace files

Creo Elements/Direct Model Manager and Creo Elements/Direct Drawing Manager

  • Export Files (*.sdexp)
  • Config Files (*.xml)
  • DB Trace Files (*.log), Oracle Trace Files (*.trc), SD LISP trace files (*.txt *.log)
  • Java Stacktrace (*.txt), WebServices Logfiles (*.log)
  • Java Heap dump (*.hprof)
  • Export Files (*.sdexp)
  • Config Files (db_defaults, passwords, *.ini)
  • Macro Trace Files (*.txt)
  • DB Trace Files (*.log), Oracle Trace Files (*.trc)
  • SD LISP trace files (*.txt, *.log)
  • DB Export files Oracle (*.dmp), SQL Server Export Files (*.bak, *.log)
  • Windows Event logs (*.evt)

If required within the case analysis, the Technical Support representative will request additional files and explain how to create and package them.

Creo Elements/Pro or Pro/ENGINEER

Follow these steps to save the latest copy of your Pro/ENGINEER or Creo Elements/Pro database objects and create a trail file that captures your issue. (Creo Elements/Pro was formerly called Pro/ENGINEER until M070.)

  1. Create a new directory where you will save a copy of your Pro/ENGINEER or Creo Elements/Pro objects. Give the directory a name that corresponds to your Technical Support case number, for example, C1234567.
  2. Retrieve the Pro/ENGINEER or Creo Elements/Pro part, assembly, or drawing with which you have an issue.
  3. Click File > Backup and enter the name of the new directory you created in step 1. This creates a copy of the Pro/ENGINEER or Creo Elements/Pro object or objects that Technical Support will use to answer your question. Always back up the highest level that the issue affects. For example, if the issue affects drawings, back up the drawing. This will automatically back up the model, part, or assembly as well.
  4. Exit Pro/ENGINEER or Creo Elements/Pro.
  5. Change directory to the directory created in step 1.
  6. If you want to save the trail file to a user-defined directory, use the config.pro option trail_dir.
  7. Restart Pro/ENGINEER or Creo Elements/Pro.
  8. Create a new trail file by choosing the minimum number of menu options needed to recreate the issue.
  9. Copy the most recent trail file that was just created (the trail.txt file with the greatest numerical suffix) to C#######.txt in the directory created in step 1. (C####### is your Technical Support case number, for example, C1234567.)
  10. Exit Pro/ENGINEER or Creo Elements/Pro when you are finished.
  11. To verify that the trail file contains your issue, run it as follows:
    1. Start Pro/ENGINEER or Creo Elements/Pro.
    2. Click Utilities > Play Trail/Training File.
    3. Enter the name of the trail file, for example, C#######.txt.

When you have finished preparing your data, see Sending the Data in this chapter.

Creo Elements/Pro Mechanica

Follow these steps to prepare files for Creo Elements/Pro Mechanica, formely Pro/ENGINEER Structural and Thermal Simulation, which includes Mechanica, before sending them to PTC for consideration:

  1. Create a new directory where you will save a copy of all necessary files associated with your question or issue.
  2. Copy the following files and directories into this new directory, using all circumstances that apply:  
  • If the problem occurs while you are working in integrated mode with Pro/ENGINEER, copy the Pro/ENGINEER part or assembly files, as well as the Simulation files, where applicable.
  • If the problem occurs during the model definition phase in independent mode and the original part or assembly is not associated with a Pro/ENGINEER model, copy only the Simulation database file.
  • If the problem occurs while you are running an analysis or design study, copy the entire subdirectory created for the analysis or design study, as well as the files identified in the two previous bulleted sections.

Following the previous steps automatically creates a trail file. When you have finished, see Sending the Data in this chapter.

Creo Elements/Pro Routed Systems Designer

To prepare a Creo Elements/Pro Routed Systems Designer file for PTC, use one of the following procedures to create a design or a package file:

To send the complete design as an .rsd file:

  1. Create a new directory where you will save a copy of all necessary files associated with your question or issue.
  2. Click File > Open Design to open the design.
  3. Click File > Pack Design to create a design file.
  4. Set the Pack Directory folder. The .rsd file of the design will be created in this folder.
  5. Using Windows Explorer, create a folder with the case number (example C123456), and place this .rsd file into that folder.
  6. Zip the entire folder to reduce the file size and avoid corruption during transfer.

To send the package file of the catalog or particular design sheets as a .pkg file:

  1. Create a new directory where you will save a copy of all necessary files associated with your question or issue.
  2. Click File > Open Design to open the design.
  3. Click File > Export > Package. Using the Arrow button, move required items to the right side Export Package Contents box.
  4. Click Browse and set the directory into which to export the package file.
  5. Enter the name for the package file.
  6. Click OK, and then click Export.
  7. Using Windows Explorer, create a folder with the case number (example C123456), and place this .pkg file into that folder.
  8. Zip the entire folder to reduce the file size and avoid corruption during transfer.

DIVISION ProductView

For DIVISION ProductView, have the following information ready to help solve your problem:

  • agent.ini file from each folder under <Graphics Server loadpoint>/ObjectAdapters.
  • Events folder contents in <Graphics Server loadpoint>.
  • worker.log file found on the CADWorker machine in the worker directory as referenced in the <Graphics Server loadpoint>/ ObjectAdapters/cad/agent.ini file. The correct location for the worker.log file is shown in the host and exe entries in the agent.ini file.
  • Repeatable steps required to duplicate the problem.

You can attach the files to an e-mail and send them using the procedure described in Sending the Data in this chapter.

Electronic Design Entry (EDE)

Gather all required data for Electronic Design Entry, including subfigures and rules files, into a single directory. Use the command schfollow to locate the subfigures used.

FlexPLM

For FlexPLM issues, have the following information ready to help solve your problem:

  • custom.lcs.properties file in <Windchill loadpoint>/codebase
  • lcs.db.properties file in <Windchill loadpoint>/db
  • MethodServer.log file in <Windchill loadpoint>/logs
  • LCS*.log files in <Windchill loadpoint>/logs (there are several LCS log files such as LCSQuery.log and  LCSDB.log)
  • localhost_LCSW_log.<DATE>.txt file in <Tomcat loadpoint>/logs

If an error page opens in FlexPLM, click the link Create Support Package. This link creates a ZIP file with the log files and property files listed above along with information about the error.

Info*Engine

Have the following information ready for assistance with Info*Engine products:

  • Info*Engine task, template, and JSP files—Include the actual template file, not a just link to the template file.
  • Server log file—Default location: <Info*Engine loadpoint>\log\server.log
  • Adapter log file (adapter.log) —Include if running the adapter in a standalone configuration.
  • Info*Engine properties file—Default location: <Info*Engine loadpoint>\ie.properites
  • Enterprise access client and method source code (EBAI adapter only).

Integrity

Please provide a detailed description and screenshots of relevant information including any error messages.

We may ask to turn on logging, to do so, run "im logging --category=<Category> --on", you can also replace "im" with "si".  Some examples:

"si logging --category=ACL --on" > Turns on ACL logging on the server

"si logging --category=DEBUG --on --target=client" > Turns on DEBUG logging on the client

"si logging --category=DEBUG --off" Turns off DEBUG logging on the server

The server log is located in <Integrity Server>\log\server.log

The client log is located in <Integrity Client>\bin\IntegrityClient.log

To collect a support package, run "im diag --diag=collectsupportpackage --output=c:\temp\supportPackage.zip" ("im" can be replaced with "si").  If you are not able to run the diag command, you can also run "collectsupportpackage c:\temp\supportPackage.zip" from the <Integrity Server>\bin directory.

  • Critical Issues
    • If at all possible, please call us prior to performing any actions as there may be additional steps that we would like to perform
  • Authentication Issues
    • Provide security.properties from the <Integrity Server>\config\properties directory
    • Replicate the issue with DEBUG & LDAP (if appropriate) logging enabled and provide the server log
    • If this is an LDAP issue then please confirm if you are able to login using an LDAP browser
  • Performance Issues
    • There are a number of areas that can be tuned.  Ideally we recommend having the PTC System Monitor (PSM) installed as this will provide us with a lot more information than what we could ever get from logs and usually also pinpoints the root cause of the issue leading to a quick resolution.
    • If you have PSM then provide the generated session (right click > Export Session) as well as the system information (Status Overview -> double click on "System Information" > right click and select "Package All Included Files")
    • If you don't have PSM, as a start, please replicate the issue with DEBUG logging enabled and provide a support package
  • Permission Issues
    • Replicate the issue with DEBUG & ACL logging enabled and provide the server log
  • Scripting Issues
    • Provide the output of the following command "im viewtrigger triggername > viewtrigger.txt"
    • Provide the script (trigger scripts are located in the <Integrity Server>\data\triggers\scripts directory)
    • If this is a custom script, do you know who created it?
    • If this is a built-in script, has it been modified at all?  (you can also take a look at the timestamp)
    • Please replicate the issue with DEBUG logging enabled and provide the server log
  • Configuration Manager / Source Issues
    • Provide details about the project structure
    • What are the exact steps that are taken?
  • Integration Issues
    • What Integration is being used?
    • What version of the integration are you using?
    • What 3rd party software is involved (including version information)
    • What are the exact steps that are taken?

Intercomm

Application files of various types help Technical Support reproduce and resolve a problem with Intercom products.

InterComm EDAcompare

For assistance with InterComm EDAcompare, have the following information ready:

  • For issues with Windchill integration, please refer to the Windchill sections of this document.
  • For issues with the standalone configuration or if you are sure that it is not a Windchill issue, have the following information available:
    • Native design file or files
    • Configuration Set used for the comparison (If no configuration set was used, create one that mirrors the comparison that you performed.)
    • Report file
    • Configuration (.properties) file and its location
    • JAVA (JRE) version
    • Browser and version
    • Log4j log file

InterComm EDAconduit

For assistance with InterComm EDAConduit, have the following information available:

  • Native design file
  • Configuration settings for the specific conduit
  • Log4j log file
  • Resulting .eda file or resulting IFF file (if using an IFF converter)

If the issue is with the display of data in InterComm Expert, also include the required data specified below for InterComm Expert.

InterComm Expert

For assistance with InterComm Expert, have the following information available:

  • For Data Display issues:
  • Native design file
    • Resulting .eda file (if applicable)
    • An annotation/bookmark file indicating the issue
  • For InterComm Expert operation issues:
    • Registry settings for InterComm Expert
    • Environment variables
    • License settings
    • ICMcontrolfile.txt

Mathcad

Follow these steps to prepare Mathcad information for technical assistance:

  1. Save your Mathcad worksheet (.xmcd).
  2. Include your version of Mathcad, and the steps to reproduce your problem.
  3. Compress the worksheet to avoid corruption during transfer. Use the case number for the ZIP file name (example: C123456.zip).

Windchill Import and Export

For issues regarding bulk loading, workflow import/export, lifecycle import/export, or sourcing import/export with Windchill, have the following information ready to help solve your problem:

  • csvmapfile.txt file in <Windchill loadpoint>/loadfiles
  • Any other .csv file related to the issue

The files must be packed in a TAR or ZIP file before they can be attached to an e-mail and sent using the procedure described in the section Sending the Data in this chapter.

Windchill Information Modeler

For Windchill Information Modeler issues, create an archive of the following files to help solve your problem:

  • Object model files—Include the .mdl file and the corresponding .cat files. The object model files are normally found under the <Windchill loadpoint>/src directory.
  • Java source files—Include source files created by the System Generator and any supporting Java source files you may have created (GUI and so forth.). These files are also normally found under the <Windchill loadpoint>/src directory.
  • SQL files—Include any .sql files created by the system generator for your object model. These files are typically found in the <Windchill loadpoint>/db/sql directory.

To create this archive, use one of the following methods:

  • On Windows—Create a ZIP file containing the files listed in the previous section. Be sure to include folder information relative to the top level of your Windchill load point.

Note: The path within the ZIP file should not include the name of the Windchill installation directory. For example, files in the src directory should contain the path src/, not Windchill/src/.

  • On UNIX—Create a TAR archive containing the files listed previously.

Note: The files in the TAR archive must be specified without the name of the Windchill installation directory.

Windchill Installation and Configuration

For Windchill installation and configuration issues, have the following information ready to help solve your problem.

  • wt.properties file in <Windchill loadpoint>/codebase
  • db.properties file in <Windchill loadpoint>/db
  • MethodServer.log file in <Windchill loadpoint>/logs
  • Environment variable listing—Generate a text file containing the current environment variable settings using the command for the appropriate platform:
    • Windows (in a Command Prompt window): set > environment.txt
    • UNIX (in a shell window): env > environment.txt
  • Output from the Java console—Open the plug-in console window.
  • Repeat the steps required to duplicate the problem.

You can attach the files to an e-mail and send them using the procedure described in Sending the Data in this chapter.

Windchill Visualization or Creo Elements/View

For Windchill Visualization or Creo Elements/View issues, have the following information ready to help solve your problem. (Creo Elements/View was formerly called ProductView 9.1 until M061.)

  • wvs.properties file in <Windchill loadpoint>/codebase
  • wt.properties file in <Windchill loadpoint>/codebase
  • agent.ini file in <Windchill loadpoint>/codebase
  • cadagent folder contents in <Windchill loadpoint>/logs
  • worker.log file found on the CADWorker machine in the worker directory as referenced in the agent.ini file. As listed in the agent.ini file, reference the host and .exe entries to find the correct location for the worker.log file.
  • Repeatable steps required to duplicate the problem.

You can attach the files to an e-mail and send them using the procedure described in Sending the Data in this chapter.