Article - CS358957

Apache Log4j Security Vulnerability - Impact on InService and Arbortext Content Delivery Products

Modified: 23-Dec-2021   


Applies To

  • PTC Arbortext Content Delivery (formerly Servigistics InService) 7.0 to 7.2
  • PTC Arbortext Content Delivery (formerly Servigistics InService) 6.0 to 6.5
  • PTC Arbortext Content Delivery A&D (formerly Servigistics InService MRO Content) 5.0 to 5.7

Description

  • A number of vulnerabilities have been reported in the 3rd party log4j library
  • This article has been created to help provide customers with information and recommended actions for
    • CVE-2021-44228 (log4j v2)
    • CVE-2021-45046 (log4j v2)
    • CVE-2021-45105 (log4j v2)
    • CVE-2021-4104 (log4j v1)
    • CVE-2019-17571 (log4j v1)
  • Due to the criticality of these vulnerabilities, it is strongly recommended to take immediate action to remediate against potential attacks
This is a PDF version of Article CS358957 and may be out of date. For the latest version click https://www.ptc.com/en/support/article/CS358957