ThingWorx Navigate Product Compatibility Matrix

Created: March 13, 2019 | Modified: September 02, 2020


For each release of ThingWorx Navigate, the support matrix lists the supported versions of Windchill, ThingWorx, and other required applications. * Refresh your browser cache to view the latest document.

Document Type

  • Matrices

Applies To

  • ThingWorx Navigate 9.0
  • ThingWorx Navigate 8.5.8
  • ThingWorx Navigate 8.5.3
  • ThingWorx Navigate 8.5.1
  • ThingWorx Navigate 8.5.0
  • ThingWorx Navigate 1.9.1
  • ThingWorx Navigate 1.9.0
  • ThingWorx Navigate 1.8.1
  • ThingWorx Navigate 1.8.0
  • ThingWorx Navigate 1.7.2
  • ThingWorx Navigate 1.7.1
  • ThingWorx Navigate 1.7.0
English