My PTC and associated tools are currently undergoing planned maintenance. Please be aware that pages may become temporarily unavailable, requiring a refresh or resubmission

Connexion
Support
Gérer et surveiller les logiciels
Apprendre
Services et expertise
Support
Gérer et surveiller les logiciels
Apprendre
Services et expertise

Vous avez basculé vers un compte différent dans un autre onglet ou une autre fenêtre ().



Votre numéro de client actif ( - ) n’est pas votre association primaire.

Voulez-vous passer maintenant à votre association primaire () ?

Rester à jour

Customer Support Guide

Les sections suivantes expliquent comment rassembler les données que vous devez envoyer au support technique de PTC pour résoudre définitivement vos problèmes avec une requête de support assisté.  Prenez connaissance de la section ou des sections ci-après portant sur le logiciel objet de votre demande de support.

NB : Si vous souhaitez communiquer des informations pour profiter du « Support communautaire assisté par PTC », sachez que toutes les données que vous publiez sur le forum communautaire sont accessibles au public et doivent donc être compatibles avec un partage public.

Arbortext

CADDS, Optegra et DIMENSION III

Creo Elements/Direct 

Creo Elements/Direct Drafting

Creo Elements/Direct Modeling

Creo Elements/Direct Model Manager et Creo Elements/Direct Drawing Manager

Creo Elements/Pro ou Pro/ENGINEER

Creo Elements/Pro Mechanica

Creo Elements/Pro Routed Systems Designer

DIVISION ProductView

Electronic Design Entry (EDE)

FlexPLM

Info*Engine

Integrity

Intercomm

InterComm EDAcompare

InterComm EDAconduit

InterComm Expert

Mathcad

Importation et exportation Windchill

Windchill Information Modeler

Installation et configuration de Windchill

Windchill Visualization ou Creo Elements/View

Arbortext

Des fichiers d'application de divers types permettent au Support technique de reproduire et de résoudre tout problème survenu avec les produits Arbortext.

  • Arbortext Editor, Arbortext Styler, Arbortext Architect (Text Editor) et Arbortext PE Interactive (auparavant appelé E3 Interactive) : pour enregistrer vos fichiers d'application, ouvrez le document source, puis sélectionnez Outils > Enregistrer l'application (Tools > Save Application). Compressez les fichiers au format ZIP.
  • A partir de la version 4.3.1, entrez la commande appsave dans la fenêtre de commande. Avant la version 4.3.1, entrez la commande bugsave.
  • Les fichiers enregistrés contiennent l'instance de document, la feuille de style, le type de document, les fichiers de programmation personnalisés et les informations relatives à l'environnement. Pour une personnalisation non standard, assurez-vous que tous les fichiers requis figurent dans le dossier appsave.
  • Pour plus de détails sur l'utilisation de la commande appsave, ouvrez le menu Rubriques d'aide (Help-Topics), cliquez sur l'onglet Rechercher (Search) et saisissez appsave dans la zone de texte.
  • Arbortext Publishing Engine, Arbortext Contributor, Arbortext Dynamic Link Manager : le Support technique vous aide à récupérer les fichiers d'application sur le serveur Arbortext Publishing Engine.
  • Arbortext Advanced Print Publisher (auparavant appelé 3B2) : préparez une version réduite du fichier *.3d qui présente le problème. Comprimez le fichier au format ZIP avec tous ses graphiques référencés.

CADDS, Optegra et DIMENSION III

Sélectionnez les fichiers des bases de données CADDS, Optegra ou DIMENSION III, comme indiqué par l'ingénieur de support technique traitant votre requête.

Creo Elements/Direct

Des fichiers d'application de divers types permettent au Support technique de reproduire et de résoudre un problème. Voici les types de fichiers classiques :

Creo Elements/Direct Drafting

  • Fichiers MI
  • Fichier de trace (echo, trace, annuler)
  • Fichiers de données IGES 2D / DXF / DWG

Creo Elements/Direct Modeling

  • Package (*.pkg) / Bundle (*.bdl) / fichiers de données 3D (*.sd*)
  • Fichiers d'enregistreur (*.rec) via (charger « enregistreur »)
  • Autres fichiers de données 3D : *.anf, *.x_t (Parasolid), IGES ou STEP
  • Fichiers de trace

Creo Elements/Direct Model Manager et Creo Elements/Direct Drawing Manager

  • Fichiers d'export (*.sdexp)
  • Fichiers de configuration (*.xml)
  • Fichiers de trace DB (*.log), Oracle (*.trc), SD LISP (*.txt *.log)
  • Suivi d'empilage Java (*.txt), fichiers journaux WebServices (*.log)
  • Vidage de pile Java (*.hprof)
  • Fichiers d'export (*.sdexp)
  • Fichiers de configuration (db_defaults, mots de passes, *.ini)
  • Fichiers de trace macro (*.txt)
  • Fichiers de trace DB (*.log) et Oracle (*.trc)
  • Fichiers de trace SD LISP (*.txt, *.log)
  • Fichiers d'export DB Oracle (*.dmp) et SQL Server (*.bak, *.log)
  • Journaux d'événements Windows (*.evt)

Si l'analyse de la requête l'exige, le représentant du support technique demandera des fichiers supplémentaires et expliquera comment les créer et les préparer.

Creo Elements/Pro ou Pro/ENGINEER

Suivez les étapes ci-dessous pour enregistrer la copie la plus récente de vos objets de base de données Pro/ENGINEER ou Creo Elements/Pro et créer un fichier journal qui capture votre problème. Creo Elements/Pro était anciennement appelé Pro/ENGINEER jusqu'à la version M070.

  1. Créez un répertoire où vous enregistrerez une copie de vos objets Pro/ENGINEER ou Creo Elements/Pro. Nommez-le en fonction du numéro de requête de support technique, par exemple C1234567.
  2. Récupérez la pièce, l'assemblage ou le dessin Pro/ENGINEER ou Creo Elements/Pro avec lequel vous avez un problème.
  3. Cliquez sur Fichier > Sauvegarder (File > Backup), puis entrez le nom du répertoire que vous avez créé à l'étape 1. Une copie de l'objet ou des objets Pro/ENGINEER ou Creo Elements/Pro est alors créée. Le Support technique l'utilisera pour répondre à votre question. Effectuez toujours la sauvegarde au niveau le plus élevé affecté par le problème. Par exemple, s'il s'agit d'un problème de dessin, une sauvegarde du dessin Cela permet également de sauvegarder le modèle (pièce ou assemblage).
  4. Quittez Pro/ENGINEER ou Creo Elements/Pro.
  5. Passez au répertoire créé à l'étape 1.
  6. Si vous souhaitez enregistrer le fichier journal dans un répertoire défini par l'utilisateur, utilisez l'option trail_dir de config.pro.
  7. Redémarrez Pro/ENGINEER ou Creo Elements/Pro.
  8. Créez un nouveau fichier journal en choisissant le nombre minimum d'options de menu nécessaires pour recréer le problème.
  9. Copiez le fichier journal le plus récent à peine créé (le fichier trail.txt avec le plus grand suffixe numérique) dans le répertoire C#######.txt créé à l'étape 1. (C####### est votre numéro de requête du support technique, par exemple, C1234567).
  10. Quittez Pro/ENGINEER ou Creo Elements/Pro lorsque vous avez terminé.
  11. Pour vérifier que le fichier journal contient votre problème, exécutez-le comme suit :
    1. Lancez Pro/ENGINEER ou Creo Elements/Pro.
    2. Cliquez sur Utilitaires > Afficher le fichier journal/didacticiel (Utilities > Play Trail/Training File).
    3. Entrez le nom du fichier journal, par exemple C#######.txt.

Lorsque vous avez terminé de préparer vos données, passez à la section Envoi des données dans ce chapitre.

Creo Elements/Pro Mechanica

Suivez les étapes définies pour préparer les fichiers dans Creo Elements/Pro Mechanica, anciennement Pro/ENGINEER Structural and Thermal Simulation, qui intègre Mechanica, avant de les envoyer à PTC pour analyse :

  1. Créez un nouveau répertoire dans lequel vous enregistrerez une copie de tous les fichiers nécessaires pour résoudre votre question ou problème.
  2. Copiez les fichiers et répertoires suivants dans ce nouveau répertoire :  
  • Si le problème s'est produit alors que vous travailliez dans Pro/MECHANICA en mode intégré avec Pro/ENGINEER, copiez les fichiers de pièce ou d'assemblage Pro/ENGINEER ainsi que les fichiers Simulation, le cas échéant.
  • Si le problème survient pendant la phase de définition du modèle en mode indépendant et que la pièce ou l'assemblage d'origine n'est pas associé à un modèle Pro/ENGINEER, copiez uniquement le fichier de la base de données de Simulation.
  • Si le problème survient pendant que vous effectuez une analyse ou une étude de conception, copiez l'intégralité du sous-répertoire créé pour l'analyse ou l'étude de conception, ainsi que les fichiers identifiés dans les deux sections de la liste précédente.

Le fichier journal sera automatiquement créé. Lorsque vous avez terminé, passez à la section Envoi des données dans ce chapitre.

Creo Elements/Pro Routed Systems Designer

Suivez l'une des procédures décrites ci-dessous pour créer un fichier d'étude ou package Creo Elements/Pro Routed Systems Designer pour PTC :

Pour envoyer la conception complète dans un fichier .rsd :

  1. Créez un nouveau répertoire dans lequel vous enregistrerez une copie de tous les fichiers nécessaires pour résoudre votre question ou problème.
  2. Cliquez sur Fichier > Ouvrir une étude (File > Open Design) pour ouvrir l'étude.
  3. Cliquez sur Fichier > Compacter l'étude (File > Pack Design) pour créer un fichier d'étude.
  4. Définissez le Répertoire du fichier de compression (Pack Directory). Le fichier .rsd de l'étude sera créé dans ce dossier.
  5. A l'aide de Windows Explorer, créez un dossier portant le numéro de requête, par exemple C123456, et placez-y le fichier .rsd.
  6. Zippez tout le dossier pour réduire la taille du fichier et éviter sa corruption pendant le transfert.

Pour envoyer le fichier préparé du catalogue ou certaines feuilles de conception dans un fichier .pkg :

  1. Créez un nouveau répertoire dans lequel vous enregistrerez une copie de tous les fichiers nécessaires pour résoudre votre question ou problème.
  2. Cliquez sur Fichier > Ouvrir une étude (File > Open Design) pour ouvrir l'étude.
  3. Cliquez sur Fichier > Exporter > Package (File > Export > Package). À l'aide du bouton Flèche, déplacez les éléments désirés dans la partie droite du cadre Contenu du package à exporter (Export Package Contents).
  4. Cliquez sur Parcourir (Browse) et définissez le répertoire d'exportation du fichier package.
  5. Entrez le nom du fichier package.
  6. Cliquez sur OK, puis sur Exporter (Export).
  7. A l'aide de Windows Explorer, créez un dossier portant le numéro de requête, par exemple C123456, et placez-y le fichier .pkg.
  8. Zippez tout le dossier pour réduire la taille du fichier et éviter sa corruption pendant le transfert.

DIVISION ProductView

Pour DIVISION ProductView, munissez-vous des informations afin que nous puissions vous aider à résoudre le problème :

  • le fichier agent.ini de chacun des dossiers se trouvant sous <point de chargement de Graphics Server>/ObjectAdapters ;
  • le contenu du dossier des événements (dossier Events) au <point de chargement de Graphics Server> ;
  • le fichier worker.log se trouvant sur la machine du convertisseur CAO dans le répertoire de travail référencé dans le fichier <point de chargement de Graphics Server>/ ObjectAdapters/cad/agent.ini. l'emplacement correct du fichier worker.log est indiqué dans les entrées host et exe du fichier agent.ini.
  • les étapes à répéter pour reproduire le problème.

Vous pouvez joindre les fichiers à un e-mail et les envoyer en suivant la procédure décrite dans la section Envoi des données de ce chapitre.

Electronic Design Entry (EDE)

Recueillez toutes les données d'Electronic Design Entry, y compris les fichiers de sous figure et les fichiers de règles (rules files), dans un répertoire unique. Utilisez la commande schfollow pour déterminer les sous figures utilisées.

FlexPLM

Pour tout problème concernant FlexPLM, rassemblez les informations suivantes :

  • le fichier de propriétés custom.lcs.properties qui se trouve dans <point de chargement Windchill>/codebase ;
  • le fichier lcs.db.properties qui se trouve dans <point de chargement Windchill>/db ;
  • le fichier MethodServer.log qui se trouve dans <point de chargement Windchill>/logs ;
  • les fichiers journaux LCS*.log qui se trouvent dans <point de chargement Windchill>/logs (plusieurs fichiers journaux LCS, tels que LCSQuery.log et LCSDB.log, sont disponibles) ;
  • le fichier localhost_LCSW_log ;le fichier <DATE>.txt qui se trouve dans <point de chargement Tomcat>/logs.

Si une page d'erreur s'ouvre dans FlexPLM, cliquez sur le lien de création d'un package de support. Ce lien crée un fichier ZIP comportant les fichiers journaux et les fichiers de propriétés répertoriés ci-dessus, ainsi que des informations relatives à l'erreur.

Info*Engine

Munissez-vous des informations suivantes pour obtenir de l'aide sur vos produits Info*Engine :

  • Tâches Info*Engine, modèle et fichiers JSP. Faites attention à inclure le véritable fichier du modèle, et pas seulement un lien vers lui.
  • Fichier journal du serveur. Emplacement par défaut : <point de chargement Info*Engine>\log\server.log
  • Fichier journal de l'adaptateur (adapter.log) : inclus si vous exécutez l'adaptateur en mode autonome.
  • Fichier de propriétés Info*Engine. Emplacement par défaut : <point de chargement Info*Engine>\ie.properties
  • Code source de la méthode et du client d'accès Enterprise (adaptateur EBAI seulement).

Integrity

Veillez à fournir une description détaillée ainsi que des impressions d'écran des informations concernées, sans oublier les messages d'erreur.

Nous pouvons vous demander d'activer la journalisation. Pour ce faire, exécutez "im logging --category=<Category> --on". Vous pouvez aussi remplacer "im" par "si".   Voici quelques exemples :

"si logging --category=ACL --on" active le journal ACL sur le serveur.

"si logging --category=DEBUG --on --target=client" active le journal de DEBUG sur le client.

"si logging --category=DEBUG --off" désactive le journal de DEBUG sur le serveur.

Le journal du serveur se trouve sous <serveur Integrity>\log\server.log

Le journal du client se trouve quant à lui sous <client Integrity>\bin\IntegrityClient.log

Pour collecter le lot d'informations destiné au Support, exécutez "im diag --diag=collectsupportpackage --output=c:\temp\supportPackage.zip" (où "im" peut être remplacé par "si").   S'il ne vous est pas possible d'exécuter la commande diag, vous pouvez exécuter "collectsupportpackage c:\temp\supportPackage.zip" à partir du répertoire <serveur Integrity>\bin.

  • Problèmes critiques
    • Dans la mesure du possible, veuillez nous appeler avant d'entreprendre n'importe quelle opération car il se peut que nous vous demandions d'effectuer des étapes supplémentaires.
  • Problèmes d'authentification
    • Fournissez-nous les propriétés relatives à la sécurité que vous trouverez dans le répertoire <serveur Integrity>\config\properties.
    • Répliquez le problème après avoir activé le journal de DEBUG et de LDAP (s'il y a lieu), puis envoyez-nous le journal du serveur.
    • S'il s'agit d'un problème LDAP, veuillez nous faire savoir si vous pouvez vous connecter à l'aide d'un navigateur LDAP.
  • Problèmes de performance
    • Il est possible d'améliorer un certain nombre de domaines.   Idéalement, nous vous recommandons d'installer PTC System Monitor (PSM). Celui-ci nous permet en effet de recueillir beaucoup plus d'informations que n'importe quels journaux et en général il est capable de déceler la cause première du problème, ce qui contribue à une solution rapide.
    • Si vous avez PSM, envoyez-nous la session générée (clic droit > Export Session) ainsi que les informations système (Status Overview -> double-cliquez sur "System Information" > clic droit et sélectionnez "Package All Included Files").
    • Si vous n'avez pas PSM, pour commencer, veuillez répliquer le problème après avoir activé le journal de DEBUG, puis envoyez-nous le lot d'informations requis.
  • Problèmes d'autorisation
    • Veuillez répliquer le problème après avoir activé le journal de DEBUG et d'ACL, puis envoyez-nous le journal du serveur.
  • Problèmes de script
    • Fournissez-nous le résultat de la commande "im viewtrigger triggername > viewtrigger.txt".
    • Fournissez-nous également le script (les scripts de déclenchement se trouvent dans le répertoire <serveur Integrity>\data\triggers\scripts directory).
    • S'il s'agit d'un script personnalisé, savez-vous qui l'a créé ?
    • S'il s'agit d'un script intégré, a-t-il jamais été modifié ? (Vous pouvez également vérifier l'horodatage.)
    • Veillez répliquer le problème après avoir activé le journal de DEBUG, puis envoyez-nous le journal du serveur.
  • Problème de source/du gestionnaire de configuration
    • Fournissez-nous des détails sur la structure du projet.
    • Quelles étapes exactes avez-vous suivies ?
  • Problèmes d'intégration
    • Quel type d'intégration est utilisé ?
    • Quelle version de l'intégration utilisez-vous ?
    • Quel logiciel tiers est impliqué ? (Indiquez la version.)
    • Quelles étapes exactes avez-vous suivies ?

Intercomm

Des fichiers d'application de divers types permettent au Support technique de reproduire et de résoudre tout problème survenu avec les produits InterComm.

InterComm EDAcompare

Pour obtenir de l'aide sur InterComm EDAcompare, munissez-vous des informations suivantes :

  • Pour les problèmes liés à l'intégration de Windchill, veuillez vous référer aux sections de ce document consacrées à Windchill.
  • Pour les questions relatives à la configuration autonome ou si vous êtes sûr qu'il ne s'agit pas d'un problème lié à Windchill, munissez-vous des informations suivantes :
    • Fichiers de conception natifs
    • Jeu de configuration utilisé pour la comparaison. Si aucun jeu de configuration n'a été utilisé, créez-en un qui reflète la comparaison que vous avez effectuée.
    • Fichier de rapport
    • Fichier de configuration (.properties) et son emplacement
    • Version JAVA (JRE)
    • Navigateur et version
    • Fichier journal Log4j

InterComm EDAconduit

Pour obtenir de l'aide sur InterComm EDAconduit, munissez-vous des informations suivantes :

  • Fichier de conception natif
  • Paramètres de configuration pour le conduit spécifique
  • Fichier journal Log4j
  • Les fichiers .eda ou IFF obtenus (si vous utilisez un convertisseur IFF)

Si le problème concerne l'affichage des données dans InterComm Expert, veuillez également inclure les données requises précisées ci-dessous pour InterComm Expert.

InterComm Expert

Pour obtenir de l'aide sur InterComm Expert, munissez-vous des informations suivantes :

  • Pour les problèmes d'affichage des données :
  • Fichier de conception natif
    • Fichier .eda obtenu (le cas échéant)
    • Fichier d'annotation/signet indiquant le problème
  • Pour les problèmes de fonctionnement d'InterComm Expert :
    • Paramètres du registre pour InterComm Expert
    • Variables d'environnement
    • Paramètres de licence
    • ICMcontrolfile.txt

Mathcad

Procédez comme suit pour préparer les informations relatives à Mathcad en vue d'une aide technique :

  1. Enregistrez votre document Mathcad (.xmcd).
  2. Incluez votre version de Mathcad et les étapes nécessaires pour reproduire votre problème.
  3. Comprimez le document pour éviter toute altération lors du transfert. Utilisez le numéro de requête dans le nom du fichier ZIP (exemple : C123456.zip).

Importation et exportation Windchill

Pour tout problème concernant le chargement de documents volumineux, l'importation et l'exportation de processus ou de cycles de vie ou l'importation ou exportation d'approvisionnement dans Windchill, munissez-vous des informations suivantes pour que nous puissions vous aider à résoudre le problème :

  • le fichier csvmapfile.txt file qui se trouve dans <point de chargement Windchill>/loadfiles ;
  • tout autre fichier .csv associé au problème.

Les fichiers doivent être compressés aux formats TAR ou ZIP avant de les joindre à un e-mail et envoyés selon la procédure décrite dans la section Envoi des données de ce chapitre.

Windchill Information Modeler

Pour les problèmes Windchill Information Modeler, créez un fichier d'archivage des fichiers suivants pour faciliter la résolution de votre problème :

  • Fichier modèle de l'objet : incluez le fichier .mdl et les fichiers .cat correspondants. Les fichiers modèles de l'objet se trouvent en principe dans le répertoire <point de chargement Windchill>/src.
  • Fichiers source Java : incluez les fichiers source créés par le générateur système ainsi que tout autre fichier source Java que vous avez créé (GUI, etc.). En principe, ces fichiers se trouvent aussi dans le répertoire <point de chargement Windchill>/src.
  • Fichiers SQL : incluez tous les fichiers .sql créés par le générateur système pour votre modèle d'objet. Ces fichiers se trouvent en principe dans le répertoire <point de chargement Windchill>/db/sql.

Pour créer cette archive, utilisez l'une des méthodes suivantes :

  • Sous Windows : créez un fichier ZIP contenant les fichiers mentionnés dans la section précédente. N'oubliez pas d'inclure les informations du dossier relatives au niveau supérieur de votre point de chargement Windchill.

Remarque : Le chemin au sein du fichier ZIP ne doit pas inclure le nom du répertoire d'installation de Windchill. Les fichiers du répertoire src, par exemple, doivent contenir le chemin src/ et non Windchill/src/.

  • Sous UNIX : créez une archive TAR contenant les fichiers mentionnés précédemment.

Remarque : Spécifiez les fichiers de l'archive TAR sans le nom du répertoire d'installation Windchill.

Installation et configuration de Windchill

Pour les problèmes d'installation et de configuration de Windchill, préparez les informations suivantes afin de faciliter la résolution de votre problème :

  • le fichier wt.properties qui se trouve dans <point de chargement Windchill>/codebase ;
  • le fichier db.properties qui se trouve dans <point de chargement Windchill>/db ;
  • le fichier MethodServer.log qui se trouve dans <point de chargement Windchill>/logs ;
  • liste des variables d'environnement : générez un fichier texte contenant les paramètres de variable d'environnement courants en utilisant la commande de la plate-forme appropriée :
    • Windows (dans une fenêtre d'invite de commandes) : set > environment.txt
    • UNIX (dans une fenêtre de l'interpréteur de commandes) : env > environment.txt
  • sortie de la console Java : ouvrez la fenêtre du module d'extension ;
  • étapes à répéter pour reproduire le problème.

Vous pouvez joindre les fichiers à un e-mail et les envoyer en suivant la procédure décrite dans la section Envoi des données de ce chapitre.

Windchill Visualization ou Creo Elements/View

Pour tout problème concernant Windchill Visualization ou Creo Elements/View, rassemblez les informations suivantes : Creo Elements/View était appelé ProductView 9.1 jusqu'à la version M061.

  • fichier wvs.properties dans <point de chargement Windchill>/codebase
  • fichier wt.properties qui se trouve dans <point de chargement Windchill>/codebase ;
  • fichier agent.ini dans <point de chargement Windchill>/codebase
  • contenu du dossier cadagent dans <point de chargement Windchill>/logs
  • fichier worker.log figurant sur la machine du convertisseur CAO dans le répertoire de travail référencé dans le fichier agent.ini ; référencez les entrées hôte et .exe telles qu'elles apparaissent dans le fichier agent.ini, afin de déterminer l'emplacement exact du fichier worker.log ;
  • étapes à répéter pour reproduire le problème.

Vous pouvez joindre les fichiers à un e-mail et les envoyer en suivant la procédure décrite dans la section Envoi des données de ce chapitre.