アーティクル - CS334518

ThingWorx と Flow に送信される受け入れられるファイルのサイズを増やす方法

修正日: 07-Jun-2023   


適用対象

  • ThingWorx Platform 8.5 to 9.3

説明

  • ThingWorx と Flow に送信される受け入れられるファイルのサイズを増やす方法
  • ThingWorx に送信されたファイルは、サイズが原因で Tomcat または Nginx (リバース プロキシとして使用されている場合) によって受け入れられません。
  • 大きなファイルを使用/受信するワークフローが失敗する
  • 大きなファイルを Flow に送信すると、Nginx はエラーをスローします。
[error] 114118#0: *123456 client intended to send too large body: 22912075 bytes, client: <ip_address>, server: <hostname>, request: "POST /Thingworx/Things/abcThing/Services/UploadFile HTTP/1.1", host: "<hostname>"
  • ThingWorx ログには次のエラーが表示されます。
Content Length (152853249) of https://thingworx.server.name/Thingworx/Things/EntityName/Services/SomeServiceName bigger then max allowed
  • web.xml の ContentLengthFilter の max-allowed-length-in-bytes パラメータの値を変更すると、Tomcat のメモリにどのような影響がありますか?
  • Tomcat の web.xml の ContentLengthFilter の max-allowed-length-in-bytes パラメータの推奨最大値はどれくらいですか?
最新バージョンはこちらを参照ください CS334518