アーティクル - CS305798
ThingWorx Platform の起動時に「構成設定 ContentTypeSettings.supportedMediaEntityContentTypes は null にできません」というメッセージが表示されます。
修正日: 16-Jun-2026
適用対象
- ThingWorx Platform 8.4 to 9.4
説明
- ThingWorxのインストール後、アプリケーションが起動しない
- プラットフォームが起動しないため、ThingWorxのインストールを完了できません。
- 起動時にデータベースエラーが表示されますが、データベース自体は稼働しています。
- ThingWorxアプリケーションが起動せず、Tomcatサービスが停止しました。
- platform-settings.json は正しく構成されていますが、ThingWorx Platform が起動しません。
- ThingworxStorage の ApplicationLog.log ファイルには次の情報が表示されます。
- [日時] [L: エラー] [O: ctsThingWorxBootstrapper] [I: ] [U: スーパーユーザー] [S: ] [T: localhost-startStop-1] [メッセージ: システムの初期化と起動に失敗しました: 基盤となるデータベースから接続を取得できませんでした!]
[日時] [L: エラー] [O: ctsThingWorxBootstrapper] [I: ] [U: スーパーユーザー] [S: ] [T: localhost-startStop-1] *** Webアプリケーションの状態がエラーに設定されました! ***
- [日時] [L: エラー] [O: ctsThingWorxBootstrapper] [I: ] [U: スーパーユーザー] [S: ] [T: localhost-startStop-1] [メッセージ: システムの初期化と起動に失敗しました: 基盤となるデータベースから接続を取得できませんでした!]
- tomcat8-stdoutログには、
- [DATE_TIME] [localhost-startStop-1] エラー com.thingworx.system.configuration.PlatformSettings - 設定 ContentTypeSettings.supportedMediaEntityContentTypes は null にすることはできません
最新バージョンはこちらを参照ください CS305798