技术文章 - CS305416

ThingWorx启动失败,并显示错误“发现存储锚点中断”。

已修改: 22-Dec-2025   


适用于

  • ThingWorx Platform 8.1 to 10.1
  • Windchill Navigate (formerly ThingWorx Navigate) 9.1 to 10.1

说明

  • ThingWorx平台Tomcat服务启动失败,错误信息位于<ThingWorx Home>\ThingworxStorage\logs\ApplicationLog.log :
     Flexara threw exception when checking for previously acquired license: Storage anchor break found.
  • 更改运行 Apache Tomcat 服务的用户后,ThingWorx 无法启动。
    • 实施CS342958文章“以指定用户身份运行 Tomcat 服务”后,ThingWorx 平台无法启动,显示许可证错误并停止运行。
    • 使用指定用户帐户运行 Tomcat 服务时,尝试启动 Tomcat 服务后服务中止。
  • 更换许可证后,ThingWorx Tomcat 无法启动
  • 升级 ThingWorx 或续订许可证时,新许可证将被忽略。
  • ThingWorx 服务因许可证连接问题而启动和停止。
  • 尽管应用了CS281516条款,ThingWorx 升级或许可证续订后,许可证文件仍被重命名为ignored_license_capability_response.bin 。许可证文件被忽略或被视为缺失。
    • 启动时, <ThingWorx Home>\ThingworxStorage\logs\ApplicationLog.log 文件中出现以下错误:
       Unable to process capability response because Storage anchor break found
    • 在 Azure Kubernetes 服务 (AKS) 中启动 ThingWorx pod 时出现以下错误:
       com.flexnet.licensing.exceptions.InternalLicensingException: Internal error: [1,7E0,8,1[72000003,0,5005F]]. at com.flexnet.licensing.baj(SourceFile:178) at com.flexnet.licensing.bit(SourceFile:3821) at com.flexnet.licensing.ad<init>(SourceFile:1035) at com.flexnet.licensing.atgetFeaturesFromTrustedStorage(SourceFile:404) at com.flexnet.licensing.atgetFeaturesFromTrustedStorage(SourceFile:392) at com.thingworx.system.subsystems.licensing.LicensingSubsystem.getFlexLicenseModelType(LicensingSubsystem.java:1041) at com.thingworx.system.subsystems.licensing.LicensingSubsystem.getLicenseModelType(LicensingSubsystem.java:890) at com.thingworx.system.subsystems.licensing.LicensingSubsystem.createLicenseManager(LicensingSubsystem.java:962) at com.thingworx.system.subsystems.licensing.LicensingSubsystem.acquireLicenseFeatures(LicensingSubsystem.java:775) at com.thingworx.system.subsystems.licensing.LicensingSubsystem.startSubsystem(LicensingSubsystem.java:455) at com.thingworx.system.subsystems.Subsystem.startInternal(Subsystem.java:206) at com.thingworx.system.ThingWorxServer.startSubsystem(ThingWorxServer.java:1332) at com.thingworx.system.ThingWorxServer.start(ThingWorxServer.java:758)
    • 在 ThingWorx 安装过程中, <ThingWorx Home>\ThingworxStorage\logs\ApplicationLog.log 文件中出现以下错误:
      •  **********LICENSING ERROR ANALYSIS [L: ERROR] [O: EcqlcLogger] [I: ] [U: SuperUser] [S: ] [P: ] [T: main] Cannot load license because Storage anchor break found. [L: ERROR] [O: EcqlcLogger] [I: ] [U: SuperUser] [S: ] [P: ] [T: main] **********END LICENSING ERROR ANALYIS [L: ERROR] [O: EcqlcLogger] [I: ] [U: SuperUser] [S: ] [P: ] [T: main] Storage anchor break found. [L: ERROR] [O: EcqlcLogger] [I: ] [U: SuperUser] [S: ] [P: ] [T: main] =====================================
    这是文章 305416 的 PDF 版本,可能已过期。最新版本 CS305416