技术文章 - CS305798
启动 ThingWorx 平台时,会看到“配置设置 ContentTypeSettings.supportedMediaEntityContentTypes 不能为空”的提示。
已修改: 16-Jun-2026
适用于
- ThingWorx Platform 8.4 to 9.4
说明
- 安装 ThingWorx 后应用程序无法启动
- ThingWorx 无法完成安装,因为平台无法启动。
- 启动时出现数据库错误,但数据库已启动并正在运行。
- ThingWorx应用程序未启动,Tomcat服务已关闭
- platform-settings.json 文件已配置且格式正确,但 ThingWorx 平台无法启动。
- ThingworxStorage 中的 ApplicationLog.log 文件显示:
- [DATE_TIME] [L: ERROR] [O: ctsThingWorxBootstrapper] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] [message: 无法初始化和启动系统:无法从底层数据库获取连接!]
[DATE_TIME] [L: ERROR] [O: ctsThingWorxBootstrapper] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] *** Web 应用程序状态已设置为 ERROR! ***
- [DATE_TIME] [L: ERROR] [O: ctsThingWorxBootstrapper] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] [message: 无法初始化和启动系统:无法从底层数据库获取连接!]
- tomcat8-stdout 日志显示
- [DATE_TIME] [localhost-startStop-1] 错误 com.thingworx.system.configuration.PlatformSettings - 配置设置 ContentTypeSettings.supportedMediaEntityContentTypes 不能为空
这是文章 305798 的 PDF 版本,可能已过期。最新版本 CS305798