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Objective: 
 
At the end of this tutorial, you will be able to: 

• Repeat the steps necessary to ensure a smooth exchange of data between the 
Electrical and Mechanical department. 

• Formulate an internal process for managing changes between the Electrical 
Engineer & the Mechanical Engineer. 

• Improve product quality. 
• Promote a concurrent design environment w/ out fear of design ramifications 

downstream and from design issues w/in your team members. 
 
Overview: 
 
In the typical design process, the Mechanical Designer defines the board shape, specifies 
important “keep in” and “keep out” areas, and places critical components such as 
connectors, switches, displays, and LED’s using Pro/Engineer.  This information is 
exported via an IDF file to the PCB designer to use as the basis for the board layout in the 
PCB layout system.  After placing the remaining components, the fully placed board 
assembly is passed back through the IDF file to the Mechanical Designer to make sure 
the board assembly fits into the final product package.  Multiple iterations of this basic 
flow typically occur during the product design phase. 
 
Why is it beneficial to the Electrical Engineer? 
The electrical engineer can communicate design requirements effortlessly to the 
Mechanical Engineer.  This information includes, hole placement, pin hole placement, 
keep in/keep out areas, and board size. 
 
Why is it beneficial to the Mechanical Engineer? 
Mechanical Engineers can specify mechanical requirements and transmit them directly to 
an electrical engineer’s PCB layout program.  Most all PCB layout programs have an 
export capability called an IDF file.  This is similar to exporting an IGES file.  The 
difference is that exact component information (placement and size) is contained within 
the file.  This information is transmitted effortlessly to the Mechanical Engineer.  With 
other translation methods, such as IGES, data is often lost in the conversion. 
 
What are the mechanical aspects that are critical to the Mechanical Engineer? 

1) Interference Checking- Accurate assemblies are created and can be joined with 
other assemblies to check interference between mating parts. 

2) Mass Properties can be calculated automatically by using a library of ECAD 
component part files that contain accurate mass property information. 

3) Static, dynamic, thermal analysis can be performed. 
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Metric: 
 
The following example illustrates the immediate impact on utilizing Pro/ECAD to 
automate Printed Wiring Assembly (PWA) design information exchange between the 
PCB design group and the mechanical engineering group. 
 
This is done to: 

1. Increase accuracy 
2. Enhance efficiency 

 
And removing need of interface drawing creation: 
 

1. Translates in 1-2 man-days saving per PWA assembly 
2. Immediate communication of design changes to Mechanical Engineering 

upon import of PCB design data 
3. Eliminates need for change documents 

 
The previous practice of exchanging drawings and DXF data resulted in longer effort 
and inaccurate results as exact component placements were difficult to establish. 
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Tutorial: 
 
What is the best way to use Pro/ECAD? 
 
You can import parts from an ECAD database in two ways: 

1. Let the Pro/ECAD translator automatically create basic 3-D extrusions of the part 
outlines as they are read in, or  

2. Use a map file to reference a library of ECAD part files you have set up 
beforehand.  

 
If you use the automatic method, a separate .prt file for each component is automatically 
created and added to the session. These files can be saved and customized in Pro/E as 
necessary to more accurately show the true shape of the component. After they are 
customized, you can use the import map file (ecad_hint.map) to substitute them for the 
automatically generated parts if you run the import process again. 
 
If you already have custom part files for ECAD components (ECAD Library), you can 
set up the map file in advance to substitute them for the automatically generated parts.  
Using this method you get a more accurate representation of the components. You will 
see examples below showing with a library and with out. 
 

A. How do I use existing PCB files with Pro/ECAD? 
 

STEP 1: Create a New Model w/ the .emn file:  
 
File > Open > To create a new model > Change your type to ECAD IDF (*.emn)  
 
Select an .emn file and provide a name for the board.  
 
The following dialog box will then appear: 
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Select Options near the bottom of the screen: 
 
Under the options tab you will see a listing of holes that will be imported.  You may want 
to shut the holes off depending on the number.  Some times you will see a number (say 
for this example 460).  This represents the pin holes in the PCB board.  Pro/Engineer will 
generate a hole for every type listed.  To reduce regeneration times turn on only the holes 
that are needed. 
 
Uncheck the first option to filter out the 460 PIN holes since they are not needed for our 
design. 
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The imported PCB board with holes and keep out/keep in areas is shown below: 

 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
Step 2: Create a new assembly 
 
File > New > Assembly > (give it a name) 
Component > Assemble > (In Session) > Select the PCB board part  
 
(Select the default constraint to assemble automatically.) 
 
Step 3:  Add the components from the .emn file. 
 
Insert > Data From File… > Change your type to ECAD IDF (*.emn) and select the 
same .emn file > Open  
 
The following options will appear in the menu: 
 

• Components: Import component library 
• Placement: Import component placement 
• Other Outline: Import other outline(s) which are 

volumes representing non-electrical items that would 
not have reference designators 

• Investig Plc: Imports component placements in 
investigate mode. This option lets you selectively 
accept or reject the placements of new or changed  
components 

• Investig Geom: Investigate component’s geometry 
changes 

• Use Def Template: Use default template for new 
Components 
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Accept the default options and select Done. 
 
The file will import all the components creating new part files.  View the model tree to 
verify this. 
 
Below is the imported assembly: 
 
1) w/out ECAD library   2) w/ ECAD library 
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B. How do I use start the board design 
 

TEP 1: Create an ECAD Area in the mode

/ a board already modeled, 

sert > Cosmetic > ECAD Area…  
 

he following menu will appear: 

• Regular Sec: Feature will regular sketc
• Project Sec: Feature will use projection

selected surface. 
• Xhatch: The created feature will be me
• No Xhatch: The created feature will no
• 3D Volume: The created feature will b
• Two Sides: Create two areas w/ the sam

sides of the board. 

efer to Key Vocabulary section for remaining
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Let’s select Xhatch > 3D Volume and select any surface for the feature to be created on. 
 
Sketch your area: 

 
 
 
 
 
 
 
 
 
 
 
 
And enter the heig
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
STEP 2: Export t
 
File > Save A Cop
 
Ensure that the typ
and select from th
 
 
 
 
 
 
Now you are ready

 

ht values to get the following result: 
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 is set to ECAD IDF (*.emn) 
 following options: 

 to import the file into your ECAD package.  
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Workflow That Enables The Best Use Of Pro/ECAD 
 
1) The Mechanical Engineer creates a PCB board inside an assembly that mounts to 

their existing hardware. 
2) Mounting holes are created. 
3) Keepin/Keepout areas are created. 
4) Connectors (from the ECAD library) are placed on the PCB board. 
5) File is exported to an IDF 3.0 file. 
6) The IDF file is read into the PCB layout program. 
7) Components are added observing the keep in and keep out areas on the board. 
8) The file is exported out of the PCB layout program back to an IDF 3.0 file. 
9) The Mechanical Engineer opens up their existing PCB board and appends the new 

IDF file.  New components are added and existing components are automatically 
moved because of the PCB layout engineer’s design change. 

 
This is a single iteration, but this can continue until the board is fully designed.  
Interference checks can be run and thermal analysis is one step away because of a fully 
designed PCB board. 
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Key Vocabulary for Pro/ECAD: 
 
ECAD:  Electrical Computer Aided Design 
 
ecad_hint.map file:  an ASCII file you use to control the following functions in the 
ECAD import-export process: 
 ·   Substituting custom made Pro/E parts for automatically extruded parts on import. 
 ·   Allowing or disallowing specified parts on import. 
 ·   Allowing or disallowing specified parts on export. 
 ·   Changing an ECAD reference designator to a different string for import (If for 
example the ECAD reference designator uses characters that are illegal in Pro/E). 
 ·   Changing an ECAD 'other outline' string for import (If for example the ECAD 
reference designator uses characters that are illegal in Pro/E). 
 
Pro/ECAD searches the working directory for ecad_hint.map and references it every 
time import occurs. If the file is empty or has no relevant information it is ignored.  
You can use the configuration option ECAD_MAPPING_FILE <path> to set a default 
location for the ecad_hint.map file. If you set a path with this config option, the 
working directory is not searched. 
 
Sample excerpt: 
 
# 
#  A template for ecad_hint.map  
# 
map_objects_by_name-> 
ECAD_NAME "CSTCS1" 
ECAD_ALT_NAME "N7414N" 
ECAD_TYPE "" 
MCAD_NAME "CSTCS1_PN-" 
MCAD_TYPE "part" 
END 
# 
map_objects_by_name-> 
ECAD_NAME "GF-1" 
ECAD_ALT_NAME "SC1A17.53-ND" 
ECAD_TYPE "" 
MCAD_NAME "GF-1_PN-" 
MCAD_TYPE "part" 
END 
# 
map_objects_by_name-> 
ECAD_NAME "J1_10" 
ECAD_ALT_NAME "A2099-ND" 
ECAD_TYPE "" 
MCAD. . . 
. 
. 
. 
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IDF:  Intermediate Data Format 
 
PCB: Printed Circuit Board.  
 
Place Keepin:  region of board within which components are placed.  
 
Place Keepout:  region of board where components cannot be placed.  
 
Place Region:  region of board to place similar components within.  
 
Pro/ECAD:  an interface tool that is available with every Pro/Engineer Foundation 
seat.  This functionality enables communication between the Electrical Engineers 
creating PCB layouts and Mechanical Engineers creating packaging for the electrical 
components. 
 
This technology enables 3D models of the PCB board, components, and connectors to 
be created and placed automatically for the Mechanical Engineer.  It also allows 
communication of keep in/keep out areas, board size, and hole placement between both 
Mechanical and Electrical Engineers.  
 
Pro/ENGINEER: the leading 3D product development solution, enabling designers 
and engineers in 31,000 companies to bring superior products to market faster.  
Spanning the entire product development process, from creative concept through 
detailed product definition to serviceability, Pro/ENGINEER delivers measurable value 
to companies of all sizes and across all industries. 
 
Route Keepin:  region of board where routing is allowed.  
 
Route Keepout:  region of board where routing is not allowed. 
 
Via Keepout:  region of board within which vias are not allowed. 
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Tutorial Evaluation: 

Name:  

Title:  Engineer      Designer      Draftsmen      Mfg. Engr.      Tech. Pubs.      Analyst   

PTC Products 
Used: 

 Foundation      Advanced Assembly Extension      Advanced Surface Extension 

 Behavioral Modeling      Intralink      Modelcheck      All 

Time using Pro/E:  0-6 months      6-12 months      1-2 years      2-5 years      5+ years 

1 – Strongly Disagree 
3 – Agree 
5 – Strongly Agree 

1. This tutorial content met my 
expectations: ………………………… 1          2          3          4          5 

2. The exercise was easy to understand: ………………………… 1          2          3          4          5 

3. This tutorial will help me on current 
projects: ………………………… 1          2          3          4          5 

4. These techniques make Pro/E a more 
effective tool: ………………………… 1          2          3          4          5 

5. These techniques will increase my speed 
using Pro/E: ………………………… 1          2          3          4          5 

What concepts/techniques learned from this tutorial will you apply on the job? 

1)  

2)  

3)  

What would you like to see as a future tutorial at your company? 

1)  

2)  

3)  

What can be done to improve these tutorials for your company? 

1)  

2)  

3)  

Additional Comments: 
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