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 PTC Product Focus  

Distributed Pro/BATCH 
 
Distributed Pro/BATCH was introduced with Pro/ENGINEER Wildfire as a new and improved 
batch processing utility.  Most customers do not realize that a powerful standalone version of this 
product is included with Pro/ENGINEER Foundation!  Standalone mode requires that the batch 
controller and Pro/ENGINEER session are both executed on the local computer.  For more 
intensive requirements, there is an optional version that operates in true distributed mode.  This 
uses a Distributed Services Manager (DSM) to administrate remote computers and tasks on the 
network as a compute farm.  This article will focus on leveraging the standalone mode. 
 
This version is a significant improvement over the former Pro/BATCH.  It supports far more 
import/export formats, is extensible via custom tasks, and has direct access to Pro/INTRALINK 
8.0 and PDMLink 8.0 workspaces. 
 
Routine tasks such as the following are good candidates for this utility: 

• Printing or Plotting drawings 
• Exporting to PDF 
• Importing / Exporting 2D & 3D data from supported interfaces (including ATB) 
• Re-save models with display preview 
• Running ModelCHECK 

Getting Started 
All required components are included with the 
Pro/ENGINEER distribution, but are not installed by 
default.  Under Pro/ENGINEER Product Features, 
Options - select Distributed Pro/BATCH to install the 
standalone components.  (PTC Distributed Services under 
Other Products on the main screen is for networked 
mode.) 
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A “DSM Light” controller must be running to register client tasks.  Create a shortcut, scheduled 
task, or service to run the following command: 
 

<proe_loadpoint>\bin\dcadsetup –force 
 
This should reply with “DCAD setup succeeded”, along with a listing of enabled services.  This 
list must include Distributed Pro/BATCH (dbatchs). 
 
Create a shortcut to the following command to start the interactive client: 
 

<proe_loadpoint>\bin\ptcdbatch.bat 
 
Specify the “Start in” folder to a working directory for log files, std.out, etc. 
 

 
 

Distributed Pro/BATCH Client 
Run the shortcut defined in the previous step.   
(Note that the standalone and network modes use the same client.) 
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For this example, we will configure a task to export Pro/E drawings to PDF. 

Global Preferences 
Select Edit > Preferences… to set values for all batch tasks. 
 
Set Default DSM to Standalone. 
 

 
 
Use Tools > Server Registry to optionally add one or more Windchill servers to specify 
locations for source or output objects.  Pro/INTRALINK 3.x is not supported. 

Task Type Definitions (TTDs) 
The DSM uses these XML files to communicate details of task(s) to be performed.  
Pro/ENGINEER includes several OOTB defaults located under <proe_loadpoint>\text\ttds.  As a 
best practice, copy these to a central standards area to make them available to everyone, and to 
preserve site-specific customizations between software updates.  From the Preferences dialog, 
you can specify these TTD Search Directories under Search Options panel. 
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Create a Task Group 
Select Action > New Task Group... (Ctrl+G). 
 
For this case, select “PLOT DRW to PDF”.  Notice the significant listing of predefined tasks!  
The matching default services are Pro/TOOLKIT applications, which are stored under 
<proe_loadpoint>\protoolkit.  A Pro/TOOLKIT license is not required to run these, but would be 
required to write your own service. 
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The new task is added.  The red box indicates that this is an unexecuted task. 
 

 
Add Objects 
Select Objects node, use folder browser icons on the right, or bucket at the top to collect files. 
 

 
 
Select the Configuration Files node to list job-specific config.pro, plot.pcf, etc.  The same 
configuration will be used for all objects under this task. 
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Select the Output node to define location where deliverables will be written. 
 

 
 
Select File > Save As… to store .dcx job file.  This captures the batch process definition in an 
XML-style file, which can be edited manually or programatically. 
 

 
Execute the Task 
Select the task group, then RMB > Start.  (Note that this can also be scheduled.) 
 
The task progress is visible from the Objects node.  It will show which entries are Working 
(green), Complete (blue), or Failed (red).  More detailed status information is available for any 
object with RMB > View Details @ DSM. 
 
The Output node will summarize output files; use RMB > View to open in associated 
application.  A log file is also written to the Output folder.   
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Execute from Command Line 
Task groups can be executed using the syntax below.  This is very useful to run from batch 
scripts and OS scheduled tasks. 
<proe_loadpoint>\bin\ptcdbatch.bat –nographics –process <full path>\<task_name>.dcx 
 
Distributed Pro/BATCH is a very powerful tool to automate various routine tasks.  Since it is 
included with all Pro/ENGINEER licenses – give it a try on your next project! 
 

More Information on Distributed Pro/BATCH 
To learn more about this product, please refer to the online Help in the Distributed Pro/BATCH 
Client (F1): 
<proe_loadpoint>\html\usascii\dbatchc\index.htm 
 

Back To Top

 PTC Commentary  

Enabling Distributed Design Collaboration Through PTC Products 
 

Click Here To View 
 

Back To Top
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 Tips of the Month  

Inheritance Features  
 
Inheritance features are a major enhancement to merge geometry features.  They also provide 
many of the benefits of Family Tables – without the overhead and data management drawbacks.  
This functionality is enabled by the Advanced Assembly Extension (AAX). 
 
These data sharing features provide a one-way associative propagation of geometry and feature 
information to derivative parts (slave).   They enable visibility into the model tree for the base 
model (master), and are fully functional – even when the reference part is not In Session.  In fact, 
there is an option to toggle the dependency (enabled by default).  Because of the one-way 
associativity, “revision bumping” is prevented on the source model – while retaining the 
flexibility necessary for downstream / variant functions. 
 
An Inheritance feature begins with all of its geometry and data identical to the reference part 
from which it is derived.  The designer can then define the following varied items: 

 
• Dimension & tolerance values 
• Suppress or Resume features 
• Annotations (including Geometric Tolerances & Symbols) 
• Parameters 
• References 
 

Typical use cases for this powerful data sharing feature are: 
• As-Cast / As-Machined models 
• Analysis / Simulation models 
• In-process models to show manufacturing evolution 
• Design variants (without family tables) 
• Hide IP from Suppliers (combined with family tables) 
• Model localization for stock material availability 

 
Multiple inheritance features can be created in the same model, and can even be nested.   In 
many cases, they are a good alternative to external copy geometry.  One advantage to this 
approach is the access to feature information directly and via relations. 

Create an Inheritance Feature 
An inheritance feature can be created in the context of an assembly, or in part mode as external.  
The benefit of creating as external is that no dependency is established to an assembly for 
relative placement.  The dashboard allows converting from one type to another.  Wildfire 3.0 
even allows toggling between merge and inheritance, but be aware that varied items will be lost.   
 
Create a new Part from the appropriate template, or Open an existing model. 
 
Select Insert > Shared Data > Merge/Inheritance… 
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Figure 1- Menu Structure 

 
The following dashboard will appear: 
 

 
Figure 2 – Inheritance Dashboard (Part mode) 

 
Select or Open a reference model. 
 
Place the reference model using assembly constraints. 
 
By default, a MERGE feature will be created.  Select to Toggle Inheritance. 
 
If you are working in the context of an activated part in an assembly, the reference type will be 
“Assembly context”, but it can be toggled to “External.” 

 
Figure 3 – Inheritance Dashboard (Assembly mode) 

 

Specify Placement

Remove Material Toggle Inheritance 

Open Model (source)

External Context 

Assembly Context 
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Dashboard Options 

 
Figure 4 -  Dashboard Option Panels 

 
• References for Annotations and Copy Datums are only available for Merge 

(Don’t worry…Annotation Features are included by default in Inheritance) 
• Refit Datums & Varied Items are only available for Inheritance 
• Note that Dependent status can be enabled / disabled. 

Define Variations 
This is similar to the functionality you may be familiar with from defining a family table.  This 
captures the variations that are applied against the master model during regeneration.  The tabs 
are self-explanatory. 
 
Select Options > Varied Items 
 

 
 
Use the fields and drop-down menus to specify “New” 
values or states. 

Resulting Feature & Model Tree 
• After completing the feature, notice that an 

expandable node appears in the Model Tree.  
The context menu (RMB) can be used to easily 
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Open Base model, Edit Definition, or Update Inheritance, etc. 

• If features under the inheritance structure are directly modified, suppressed, etc. in this 
context – they will automatically be added to the Varied Items table shown in the 
previous section.  This is a great ease-of-use technique! 

Accessing Relations and Parameters 
Use the following syntax to access the inherited parameters and dimension symbols of the base 
model: 
 

symbolic_name:IID_#   
 
- symbolic_name is the dimension symbol or parameter name 
- # is the internal ID of the inheritance feature 

 
Local parameters of the inheritance feature are accessed using: 
 

param_name:FID_# 
 
- # is the feature ID of the inheritance feature 

 
These can be combined to access the feature parameters of a the inherited feature: 
 
 param_name:FID_#:IID_# 

More Information on Inheritance Features 
This was just an introduction to raise awareness about this powerful and flexible capability to 
add to your design toolbox.  For more information, and some practial applications, please review 
the following great resources: 

• Pro/ENGINEER Help Center - Assembly > Top Down Design > Data Sharing 

• PTC Knowledge Base 

• PTC Express, March 2007 – Data Sharing to Protect IP 

• PTC/USER 2007 User Presentation – Inheritance Features vs. Family Tables 
  

Good Designing! 
 

Back To Top

 Commentary Tip of the Month  

Important Factors for a Distributed Design Environment   
 

Click Here To View 
 

Back To Top

Customer PTC E-Newsletter 10/1/2007 Page 11 of 15 

http://www.ptc.com/search/cs/kdb/results.jsp?lang=en&DN=1&Group1=&Sort1=&NDD=&c=kdb_search&display_type=&QS=inheritance+feature&QT=32&Product1=Pro%2FENGINEER&Module1=&Release1=&KDBLIB=cs_kdb2_tan&KDBLIB=cs_kdb2_tpi&KDBLIB=cs_kdb_howto&KDBLIB=cs_kdb2_spr&Language=en
http://www.imakenews.com/ptcexpress/e_article000760491.cfm?x=b11,0,w
http://www.ptcuser.org/2007/updates/Iverson.ppt
http://members.shaw.ca/jpeng/newsletter/PTC_Technical_Specialists_E-Newsletter_10-01-2007_enterprise.pdf


 Announcements  
 

Educational Resource Library 
 
Learn things you always wanted to do - but didn't know you could. 
This one stop educational resource library will help you learn more about PTC Solutions and 
provide you with technical materials developed by the product experts to help you become more 
productive. 

Get tutorials, how-to videos and expert advice for:  

 Pro/ENGINEER  

 Conceptual and Industrial Design  
 Detailed Design  
 Simulation/Analysis  
 Production  
 Design Collaboration  

 Windchill PDMLink  

 Windchill ProjectLink  

 Pro/INTRALINK  

 PTC Online Tools 

 
Check out the Educational Resource Library today. 
  

PTC Tips & Techniques Newsletter Archives 

Miss an issue!  Can’t find that awesome technique you read about?  Fear not, you can click on 
the link below and go through our Customer PTC E-Newsletter archives. 

Click Here To Access 

It’s better than finding the Covenant of the Ark! 
 

PTC Tips & Techniques Webcasts: Work Smarter. Not Harder. 

Click below to see regularly scheduled Tips & Techniques technical Webcasts that are designed 
to provide you with the most popular time-saving tricks that Pro/ENGINEER users of all skill 
levels will find useful.  Get more out of your maintenance dollars! 

Tips & Techniques:  Work Smarter Not Harder!

 
 
E-PROFILES IS HERE!! 
We have been eagerly anticipating the debut of the new electronic version of Profiles Magazine 
and now it is here!  This new web site will supplement the print edition of the magazine and will 
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provide new useful features not feasible with paper media.  e-Profiles will provide you with 
24x7, worldwide access to key information previously available exclusively in the print version.  
"Tips & Tricks," a popular feature pioneered by Pro/USER, has also moved to the web and will 
be expanded as the site matures.   
Please take a few minutes to check out this new web site. We don't think you will be 
disappointed. 
 
http://profilesmagazine.com/
 
 
 
 

Back To Top
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 Upcoming Events & Training Class Schedules  
 
Upcoming, 2007  Your local Pro/Engineer User Groups 
    http://www.ptcuser.org/rugs/
 
June 1 – 4, 2008  Long Beach, CA USA 

PTC/USER World Event 
http://www.ptcuser.org/ 

 

Events 
Our seminars and conferences seek to provide you with relevant information regarding product 
development trends in your industry as well as innovative software learning experiences. Think 
of them as a constructive day off where you can share experiences and swap ideas with your 
peers.  
If you can't manage to get away, we'll bring it to you. Check back often for regularly scheduled 
live webcast events. 
 

You’re Invited to Attend…

 

Please visit the PTC Education Services website for the latest training information 
including course descriptions, schedules, locations, and pricing. 
 

• Attend a course at any PTC Center and receive a free copy of Pro/ENGINEER Wildfire 
Student Edition! 

 
http://www.ptc.com/services/edserv/index.htm

 

Live Instructor-Lead Virtual PTC Training Courses 

Virtual Classrooms provide interactive learning with a trained PTC instructor in convenient and 
manageable sessions that last approximately 4 hours over a series of days.  It's easy to join a 
class right from your desk using a phone or voice-over IP technology.  

Sessions are performed just like a traditional ILT (including interactive exercises where you and 
the instructor can work on lab exercises together) and feature some of our most popular ILT 
courses.  These sessions cover the exact same material as the traditional ILT in-center courses.  
Also look for some of our most frequently requested mini-topics delivered in the same format 
that are only an hour - two hours in duration.  

If you have any questions about these sessions or would like to see getting other courses, not on 
this list, on the schedule please feel free to contact me for more details.  They are a great way to 
bring training to you without you having to worry about location or being out from work for long 
stretches.  
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You can register for these sessions just as you would for any normal ILT class either by:  

1. calling order admin at http://www.ptc.com/services/edserv/training/registra.htm or 

2. you can go to PTC University directly at http://www.ptc.com/learning and submit a 
registration request directly.  All you have to do is search the catalog by typing in 
“virtual” in the search field and you will see a listing. 

 
 
PTC 

Note: This PTC E-Newsletter will continue to be used for the following: 

1) Inform you on events related to PTC products (user groups, conferences, training schedules, etc.) 

2) Educate you on solutions that are available at PTC 

3) Tips & Techniques using PTC Products 

Note: These messages are compiled in the local PTC office and will be distributed via 
e-mail.   

Back To Top
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